Title

matlab版本问题

938次浏览

问题描述

我在10版本上运行的直驱风机模型没有问题,但考虑到15版本上有更多可以直接利用的模块,比如超级电容模块,但是发现15版本的打开10版本的出现错误不知道该怎么修正


头像

春天来了·100.00

2017-04-17提问

分数   时间  

全部答案 4

0
已采纳

已采纳

这个问题就是工作目录出错了,我用matlab2015时也会有这个问题,工作目录不能使默认的bin文件夹下。

修正方法:

本人用的这个种方法,感觉很简单快捷

http://jingyan.baidu.com/article/ff42efa921cdf0c19f220279.html

不过这种方法需要每次打开都要设定一次,貌似无法保存


另外麻烦点的方法:

http://jingyan.baidu.com/article/495ba841f60b2238b20ede7c.html

我也试过,貌似需要多设置几次才能有效,我设定了好几次,前几次不知道为什么工作目录就是改不了,但是不知道为什么后面一次就ok了。

评论 (1)条评论
头像

  mushine·70.00

2017-04-19回答

The block diagram 'Detailed_PMSG_one_machine' uses bus signals. However, the 'Mux blocks used to create bus signals' diagnostic is not configured to 'error'. To prevent modeling errors: (1) Open Upgrade Advisor and run the 'Check for Mux blocks used to create bus signals' check. (2) Follow the recommendations from this check to make your model compliant. Component: Simulink | Category: Model error 你好 就是把仿真过程中也出现了这样的错误 怎么调也10版本上没有出现在15版本上却出现了  春天来了 2017-04-19

0

换一个工作目录试试,把你的mdl文件放到其他盘符,matlab的仿真目录也放在这个目录下

评论 (0)条评论
头像555

  行者无疆·100.00

2017-04-18回答

0

运行路径不对,把模型里面的M文件和mdl文件一并放在一个文件夹打开

评论 (0)条评论
头像555

  Earljing·140.00

2017-04-17回答

3 条记录 1/1 页

撰写答案

Document